404 error

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

404 error

Doug Hall-6
I get the error:

The requested URL
/<fully_qualified_default_directory>/web_static/docs/minutes/mgr2016/2016-11-14.pdf
was not found on this server

...even though I can copy the URL and "open" the file directly from the
command line. My Safe Docs directory variable in Active4D.ini does include
the  "web_static" folder:

safe doc dirs = <default>/web_static

Any ideas what else I need to look at?

Thanks,
Doug Hall
_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/
Reply | Threaded
Open this post in threaded view
|

Re: 404 error

Doug Hall-6
Found it. It's not looking for the fully qualified path for the URL. It's
looking for a relative path from my web_static folder.

Thanks anyway.
Doug

On Wed, Oct 11, 2017 at 1:24 PM, Doug Hall <[hidden email]> wrote:

> I get the error:
>
> The requested URL /<fully_qualified_default_directory>/web_static/docs/minutes/mgr2016/2016-11-14.pdf
> was not found on this server
>
> ...even though I can copy the URL and "open" the file directly from the
> command line. My Safe Docs directory variable in Active4D.ini does include
> the  "web_static" folder:
>
> safe doc dirs = <default>/web_static
>
> Any ideas what else I need to look at?
>
> Thanks,
> Doug Hall
>
_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/
Reply | Threaded
Open this post in threaded view
|

Re: 404 error

Aparajita Fishman
I think you can understand the security implications if you could download any document from the server by putting in the full path in the address!

All the best,

  - Aparajita

> On Oct 11, 2017, at 12:17 PM, Doug Hall <[hidden email]> wrote:
>
> Found it. It's not looking for the fully qualified path for the URL. It's
> looking for a relative path from my web_static folder.
>
> Thanks anyway.
> Doug
>
> On Wed, Oct 11, 2017 at 1:24 PM, Doug Hall <[hidden email]> wrote:
>
>> I get the error:
>>
>> The requested URL /<fully_qualified_default_directory>/web_static/docs/minutes/mgr2016/2016-11-14.pdf
>> was not found on this server
>>
>> ...even though I can copy the URL and "open" the file directly from the
>> command line. My Safe Docs directory variable in Active4D.ini does include
>> the  "web_static" folder:
>>
>> safe doc dirs = <default>/web_static
>>
>> Any ideas what else I need to look at?
>>
>> Thanks,
>> Doug Hall
>>
> _______________________________________________
> Active4D-dev mailing list
> [hidden email]
> http://list.aparajitaworld.com/listinfo/active4d-dev
> Archives: http://active4d-nabble.aparajitaworld.com/


_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/
Reply | Threaded
Open this post in threaded view
|

Re: 404 error

Doug Hall-6
Yes! Thank you for saving me from my stupid self!

On Wed, Oct 11, 2017 at 3:05 PM, Aparajita Fishman <[hidden email]>
wrote:

> I think you can understand the security implications if you could download
> any document from the server by putting in the full path in the address!
>
> All the best,
>
>   - Aparajita
>
> > On Oct 11, 2017, at 12:17 PM, Doug Hall <[hidden email]> wrote:
> >
> > Found it. It's not looking for the fully qualified path for the URL. It's
> > looking for a relative path from my web_static folder.
> >
> > Thanks anyway.
> > Doug
> >
> > On Wed, Oct 11, 2017 at 1:24 PM, Doug Hall <[hidden email]>
> wrote:
> >
> >> I get the error:
> >>
> >> The requested URL /<fully_qualified_default_directory>/web_static/docs/
> minutes/mgr2016/2016-11-14.pdf
> >> was not found on this server
> >>
> >> ...even though I can copy the URL and "open" the file directly from the
> >> command line. My Safe Docs directory variable in Active4D.ini does
> include
> >> the  "web_static" folder:
> >>
> >> safe doc dirs = <default>/web_static
> >>
> >> Any ideas what else I need to look at?
> >>
> >> Thanks,
> >> Doug Hall
> >>
> > _______________________________________________
> > Active4D-dev mailing list
> > [hidden email]
> > http://list.aparajitaworld.com/listinfo/active4d-dev
> > Archives: http://active4d-nabble.aparajitaworld.com/
>
>
> _______________________________________________
> Active4D-dev mailing list
> [hidden email]
> http://list.aparajitaworld.com/listinfo/active4d-dev
> Archives: http://active4d-nabble.aparajitaworld.com/
_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/