No Cookie

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

No Cookie

Justin Will
I am helping a customer that recently upgraded to 4D 15.2 and A4D 6.3.  During some testing this past Friday we discovered that the session cookie was never being set in the browser.  After trying everything we could think of we downloaded the A4D demo database and tried that and found that the cookie was not getting set here either.  We are using the built in 4D webserver and not NTK.  Is there something we are missing here?

Thanks
Justin Will
_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/
Reply | Threaded
Open this post in threaded view
|

Re: No Cookie

Aparajita Fishman
Turn debug logging on and check the Active4D log. Did you set the “session handler” option in Active4D.ini?

Many thanks,

  - Aparajita

> On Aug 7, 2016, at 7:46 PM, Justin Will <[hidden email]> wrote:
>
> I am helping a customer that recently upgraded to 4D 15.2 and A4D 6.3.  During some testing this past Friday we discovered that the session cookie was never being set in the browser.  After trying everything we could think of we downloaded the A4D demo database and tried that and found that the cookie was not getting set here either.  We are using the built in 4D webserver and not NTK.  Is there something we are missing here?
>
> Thanks
> Justin Will
> _______________________________________________
> Active4D-dev mailing list
> [hidden email]
> http://list.aparajitaworld.com/listinfo/active4d-dev
> Archives: http://active4d-nabble.aparajitaworld.com/


_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/
Reply | Threaded
Open this post in threaded view
|

Re: No Cookie

Justin Will
In reply to this post by Justin Will
The session handler option does not exist in the demo database's Active4D.ini file for either NTK or 4D.  Am I missing something?

Justin
_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/
Reply | Threaded
Open this post in threaded view
|

Re: No Cookie

Justin Will
In reply to this post by Justin Will
So I have enabled the debug log and included the contents below.  My actions were as follows.

Open the A4D demo database using 4D v15.2 with 4D as the web hosting.

Goto the page:  http://127.0.0.1:8080/sessions/sed

Set a session of Test and value 123.

Click Sessions in the leftnav and then the Try the session editor link.  At the bottom of this page I receive the message "there is no current session"

Also when looking at my cookes in chrome the A4D cookies were never set.

Here's the Debugg log.

Aug 11 22:48:03 Active4D: [notice] *****************************************************************
Aug 11 22:48:03 Active4D: [notice]   Active4D
Aug 11 22:48:03 Active4D: [notice] *****************************************************************
Aug 11 22:48:03 Active4D: [info] env: log level = debug
Aug 11 22:48:03 Active4D: [debug] env: looking for ICU data in plugin bundle
Aug 11 22:48:03 Active4D: [info] env: ICU data directory: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\Plugins\Active4D.bundle\Contents\Resources
Aug 11 22:48:03 Active4D: [info] env: Active4D 6.3r2 [Windows, release, 32-bit]
Aug 11 22:48:03 Active4D: [info] env: 4D v15.0.2r0 [Mono, interpreted, Unicode mode, Windows 8.1, 32-bit]
Aug 11 22:48:03 Active4D: [debug] env: Windows user locale: en_US
Aug 11 22:48:03 Active4D: [info] env: ICU locale: en_US - English (United States)
Aug 11 22:48:03 Active4D: [info] env: checked
Aug 11 22:48:03 Active4D: [info] license: searching for key file in /C/Users/Justin Will/AppData/Roaming/4D/com.aparajita/Active4D
Aug 11 22:48:03 Active4D: [info] license: searching for key file in /C/ProgramData/4D/Licenses/com.aparajita/Active4D
Aug 11 22:48:03 Active4D: [info] license: searching for key file in /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Plugins/Active4D.bundle/Contents/Resources
Aug 11 22:48:03 Active4D: [warn] license: key file not found
Aug 11 22:48:03 Active4D: [info] license: type = trial, timeout: 2016-08-12 06:48:03
Aug 11 22:48:03 Active4D: [info] server: initialized
Aug 11 22:48:03 Active4D: [info] lexer: initialized
Aug 11 22:48:03 Active4D: [debug] lexer: decimal point='.', grouping separator=','
Aug 11 22:48:03 Active4D: [info] interpreter: default directory: C:/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/
Aug 11 22:48:03 Active4D: [info] interpreter: initialized
Aug 11 22:48:03 Active4D: [info] runtime: initialized
Aug 11 22:48:03 Active4D: [info] web_runtime: initialized
Aug 11 22:48:03 Active4D: [info] housekeeper: initialized
Aug 11 22:48:03 Active4D: [info] plugin: starting up web server
Aug 11 22:48:03 Active4D: [info] config: reading C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\Active4D\Active4D.ini
Aug 11 22:48:03 Active4D: [info] config: root = /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/web/ (default)
Aug 11 22:48:03 Active4D: [debug] config: allowed methods = GET, POST, OPTIONS, HEAD (default)
Aug 11 22:48:03 Active4D: [debug] config: lib dirs = <default>/libs
Aug 11 22:48:03 Active4D: [debug] config: safe script dirs =
Aug 11 22:48:03 Active4D: [debug] config: safe doc dirs = <web>/../web_static
Aug 11 22:48:03 Active4D: [debug] config: default page = index.a4d
Aug 11 22:48:03 Active4D: [debug] config: encrpyted = false (default)
Aug 11 22:48:03 Active4D: [debug] config: error page =
Aug 11 22:48:03 Active4D: [debug] config: fusebox page =
Aug 11 22:48:03 Active4D: [debug] config: executable extensions = .a4d .a4p .php
Aug 11 22:48:03 Active4D: [debug] config: serve nonexecutables = true (default)
Aug 11 22:48:03 Active4D: [debug] config: lib extension = .a4l (default)
Aug 11 22:48:03 Active4D: [debug] config: auto refresh libs = true (default)
Aug 11 22:48:03 Active4D: [debug] config: refresh interval = 5 (default)
Aug 11 22:48:03 Active4D: [debug] config: script timeout = 999
Aug 11 22:48:03 Active4D: [debug] config: receive timeout = 3600 (default)
Aug 11 22:48:03 Active4D: [debug] config: locale = en_US (default)
Aug 11 22:48:03 Active4D: [debug] config: platform charset = utf-8
Aug 11 22:48:03 Active4D: [debug] config: output charset = utf-8
Aug 11 22:48:03 Active4D: [debug] config: max request size = 2097152
Aug 11 22:48:03 Active4D: [debug] config: cache control = no-cache (default)
Aug 11 22:48:03 Active4D: [debug] config: expires = -1 (default)
Aug 11 22:48:03 Active4D: [debug] config: nonexecutable expires = 525600 (default)
Aug 11 22:48:03 Active4D: [debug] config: auto create vars = false (default)
Aug 11 22:48:03 Active4D: [debug] config: parameter mode = 0 (default)
Aug 11 22:48:03 Active4D: [debug] config: use sessions = true (default)
Aug 11 22:48:03 Active4D: [debug] config: log level = 7
Aug 11 22:48:03 Active4D: [debug] config: auto relate many = false (default)
Aug 11 22:48:03 Active4D: [debug] config: http error page =
Aug 11 22:48:03 Active4D: [debug] config: session handler = <memory> (default)
Aug 11 22:48:03 Active4D: [debug] config: session cookie name = ACTIVE4D_SESSIONID (default)
Aug 11 22:48:03 Active4D: [debug] config: session variable name = a4dtst
Aug 11 22:48:03 Active4D: [debug] config: session cookie domain = 15
Aug 11 22:48:03 Active4D: [debug] config: auto relate one = false (default)
Aug 11 22:48:03 Active4D: [debug] config: session timeout = 10 (default)
Aug 11 22:48:03 Active4D: [debug] config: session cookie path = / (default)
Aug 11 22:48:03 Active4D: [debug] config: session cookie secure = false (default)
Aug 11 22:48:03 Active4D: [debug] config: session purge interval = 10 (default)
Aug 11 22:48:03 Active4D: [info] realms: reading C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\Active4D\Realms.ini
Aug 11 22:48:03 Active4D: [debug] realm: name = realm_test; match = ?action=realms.authenticate
Aug 11 22:48:03 Active4D: [info] virtual hosts: reading C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\Active4D\VirtualHosts.ini
Aug 11 22:48:03 Active4D: [debug] virtual host: ip = ; host = "localhost:8080"; language = ""; root = /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/web/; virtual host = "local"; default = "index.a4d"
Aug 11 22:48:03 Active4D: [warn] virtual host: invalid root: Essen
Aug 11 22:48:03 Active4D: [debug] virtual host: ip = 127.0.0.1; host = ""; language = ""; root = /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/web/; virtual host = "main"; default = "index.a4d"
Aug 11 22:48:03 Active4D: [info] cors: reading C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\Active4D\Cors.ini
Aug 11 22:48:03 Active4D: [debug] cors: url = <a href="http://localhost:8080;">http://localhost:8080; origin = <origin>; methods = GET, POST, PUT, DELETE; headers = X-Requested-With, Content-Type, Origin; credentials = ; max-age =
Aug 11 22:48:03 Active4D: [info] extension map: reading C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\Active4D\ExtensionMap.ini
Aug 11 22:48:03 Active4D: [debug] extension map:
.7z       application/x-7z-compressed
.aif      audio/x-aiff
.aifc     audio/x-aiff
.aiff     audio/x-aiff
.au       audio/basic
.avi      video/x-msvideo
.bin      application/x-macbinary
.bmp      image/bmp
.class    application/octet-stream
.css      text/css
.dcr      application/x-director
.dir      application/x-director
.doc      application/msword
.dv       video/octet-stream
.dxr      application/x-director
.eot      application/vnd.ms-fontobject
.eps      application/postscript
.exe      application/octet-stream
.gif      image/gif
.gz       application/x-gzip
.hqx      application/mac-binhex40
.htc      text/x-component
.htm      text/html
.html     text/html
.ico      image/x-icon
.j        text/vnd.cappuccino.objective-j
.jar      application/octet-stream
.java     application/octet-stream
.jpeg     image/jpeg
.jpg      image/jpeg
.jpg      image/pjpeg
.js       application/javascript
.kml      application/vnd.google-earth.kml+xml
.kmz      application/vnd.google-earth.kmz
.map      application/json
.mid      audio/midi
.midi     audio/midi
.mov      video/quicktime
.mp3      audio/mpeg
.mpeg     video/mpeg
.mpg      video/mpeg
.otf      font/font-sfnt
.pct      image/x-macpict
.pct      image/x-pict
.pdf      application/pdf
.pict     image/pict
.plist    text/vnd.cappuccino.plist
.png      image/png
.ppt      application/vnd.ms-powerpoint
.ps       application/postscript
.qcp      audio/vnd.qcelp
.qt       video/quicktime
.qtvr     video/quicktime
.ra       application/x-pn-realaudio
.ram      application/x-pn-realaudio
.sgml     text/sgml
.shtm     text/html
.shtml    text/html
.sit      application/x-stuffit
.sitx     application/x-stuffitx
.sj       application/javascript
.spl      application/futuresplash
.swa      application/x-director
.swf      application/x-shockwave-flash
.tar      application/x-tar
.text     text/plain
.tgz      application/x-gzip
.tif      image/tiff
.ttf      font/font-sfnt
.txt      text/plain
.wav      audio/x-wav
.woff     font/x-woff
.word     application/msword
.wrl      x-world/x-vrml
.xbm      image/x-xbm
.xl       application/vnd.ms-excel
.xls      application/vnd.ms-excel
.xml      text/xml
.zip      application/zip

Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Active4D/Active4D.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "Active4D"
Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Active4D/Breadcrumbs.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: executing Breadcrumbs.__load__
Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Active4D/a4d.web.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "a4d.web"
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "Breadcrumbs"
Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Active4D/fusebox.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Active4D/fusebox.conf.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "fusebox.conf"
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "fusebox"
Aug 11 22:48:03 Active4D: [info] plugin: initializing circuits
Aug 11 22:48:03 Active4D: [info] plugin: scanning for circuits in web root /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/web/
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\checker
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo\app
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo\app\ingredients
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo\app\units
Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/web/demo/app/units/units.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: executing units.__load__
Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Active4D/RowSet.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: executing RowSet.__load__
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "RowSet"
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "units"
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo\app\vendors
Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/web/demo/app/vendors/vendors.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: executing vendors.__load__
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "vendors"
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo\login
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo-ajax\app
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo-ajax\app\vendors
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo-ajax
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\demo-ajax\login
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques\authentication
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques\errors
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques\execute
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques\image
Aug 11 22:48:03 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/web/techniques/image/image.a4l
Aug 11 22:48:03 Active4D: [debug] interpreter: loaded library "image"
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques\json
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques\sessions
Aug 11 22:48:03 Active4D: [info] plugin: found circuit: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques\uploads
Aug 11 22:48:03 Active4D: [info] plugin: running circuit __init__: C:\Users\Justin Will\Desktop\Active4D-v63r2\Active4D-demo.4dbase\web\techniques\uploads\__init__.a4d
Aug 11 22:48:03 Active4D: [info] plugin: circuits initialized
Aug 11 22:48:03 Active4D: [info] server: http get body method set to "A4D_GetHttpBodyCallback"
Aug 11 22:48:03 Active4D: [info] plugin: web server started, 4D host, listening on 0.0.0.0:8080
Aug 11 22:48:09 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Active4D/fusebox.head.a4l
Aug 11 22:48:09 Active4D: [debug] interpreter: loaded library "fusebox.head"
Aug 11 22:48:09 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/Active4D/a4d.debug.a4l
Aug 11 22:48:09 Active4D: [debug] interpreter: loaded library "a4d.debug"
Aug 11 22:48:09 Active4D: [debug] interpreter: loading library /C/Users/Justin Will/Desktop/Active4D-v63r2/Active4D-demo.4dbase/libs/demo.a4l
Aug 11 22:48:09 Active4D: [debug] interpreter: executing demo.__load__
Aug 11 22:48:09 Active4D: [debug] interpreter: loaded library "demo"

_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/