Syntax Error with APPLY TO SELECTION?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Syntax Error with APPLY TO SELECTION?

John Bellos
I fear I'm missing something simple but I can't figure out why this code is failing in the context of Active 4D:

                ALL RECORDS([Staff])
                READ WRITE([Staff])
                APPLY TO SELECTION([Staff];[Staff]isPrimaryProvider:=True)

The webpage returns an error on this line:
APPLY TO SELECTION([Staff];[Staff]isPrimaryProvider:=True)
Syntax error

The first open parenthesis "(" is highlighted in red.

I also tried the a4d method 'applytoselection' and got the same error.

I'm using Active4D 6.3r2 [Windows, release, 32-bit]

-
John Bellos


_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/
Reply | Threaded
Open this post in threaded view
|

Re: Syntax Error with APPLY TO SELECTION?

Aparajita Fishman

> I fear I'm missing something simple but I can't figure out why this code is failing in the context of Active 4D:
>
>                ALL RECORDS([Staff])
>                READ WRITE([Staff])
>                APPLY TO SELECTION([Staff];[Staff]isPrimaryProvider:=True)

Yes, you are missing something simple. Consulting the documentation for the list of supported 4D commands reveals the cause; the bottom of page 244 reveals the solution.

What version of 4D?

Regards,

   - Aparajita

_______________________________________________
Active4D-dev mailing list
[hidden email]
http://list.aparajitaworld.com/listinfo/active4d-dev
Archives: http://active4d-nabble.aparajitaworld.com/